agent doesn't ring phone

For subjects not covered elsewhere

agent doesn't ring phone

Postby ipvinner » Thu Aug 01, 2013 11:01 am

Hello everybody. I have added phones, and agents, phones are registering on the asterisk successfully and can ring out from carrier(SIP-trunk), but agent web-page return error: Your phone has either not been answered, or hung up! nothing happened in the asterisk cli, can you help how to fix that?
ipvinner
 
Posts: 13
Joined: Wed Jul 31, 2013 7:49 am

Re: agent doesn't ring phone

Postby fadmin » Thu Aug 01, 2013 5:41 pm

If your phone is actually registered with Asterisk, the PBX in OSDial, but when you get a disconnect msg your connection between them is not up to par. In other words Asterisk is not able to keep the connection up with the phone and tells OSDial which then shows that message.

The most common mistake is not having the phone actually registered with Asterisk but with a carrier and thinking because they can dial out through the carrier that OSDial is broken. When in reality the phone is not registered with Asterisk.

We see people buy cheap network equipment or have misconfigured networks which causes these type of problems.

Login to the dialer, fire up the CLI (rasterisk), type 'sip show peers' and make sure that a specific phone is registered. Then login as an agent with that extension, the phone should ring and play the message "You are the only one in this conference."

If it does not then the phone or your network has an issue. Unless of course you changed the OSDial config for the phone to not work. But on a default install that will not be the case.
Forum Administrator
OSDial
http://osdial.com
fadmin
Site Admin
 
Posts: 283
Joined: Fri Feb 12, 2010 7:27 am

Re: agent doesn't ring phone

Postby ipvinner » Fri Aug 02, 2013 2:13 am

I have used xLite 4.5 softphone
Code: Select all
sip show peers
3605/3605                 192.168.0.79                             D   a             35652    OK (4 ms)


what do you mean "specific phone"?
ipvinner
 
Posts: 13
Joined: Wed Jul 31, 2013 7:49 am

Re: agent doesn't ring phone

Postby ipvinner » Fri Aug 02, 2013 2:52 am

there is extention error 28601000 in the /var/log/osdial/action_full.2013-08-02
Code: Select all
2013-08-02 8:36:46|1||Response: Error
Message: Extension does not exist.


how osdial determine this extention, should I add this manually in the extentions.conf?
ipvinner
 
Posts: 13
Joined: Wed Jul 31, 2013 7:49 am

Re: agent doesn't ring phone

Postby fadmin » Fri Aug 02, 2013 11:05 am

After following your various posts something is becoming clear, either the download or install is corrupted or someone made manual changes because what you describe cannot happen from a default install.
Forum Administrator
OSDial
http://osdial.com
fadmin
Site Admin
 
Posts: 283
Joined: Fri Feb 12, 2010 7:27 am


Return to General

Who is online

Users browsing this forum: Embelmked, Fapssoamip, joannayo1, kenub3, Knifiatnon, Watacete and 1 guest

cron